GCC is the Gnu Compiler Collection. We use it as the back end C compiler for Cyclone. We use some special features of gcc, so, other C compilers won’t work.

Cyclone up to version 1.0 works best with some variant of gcc version 3 (3.4, 3.3, etc.). Unfortunately, version 1.0 does not work with version 4 of gcc, and Cyclone’s configure script will complain if your C compiler is gcc version 4.

Newer versions of Cyclone (in our SVN repository) will work with gcc 4. Instructions for accessing the SVN version are given in Download.

You can see your gcc version by running

gcc --version